HMT Available balances not visible for some accounts (Dashboard)
Incident Report for hCaptcha
Resolved
This incident has been resolved.
Posted Sep 28, 2019 - 01:12 UTC
Identified
A third party data provider is currently suffering an outage, causing Available balances to be intermittently unavailable. All other functionality is unaffected. A fix is being implemented and should be live shortly.
Posted Sep 27, 2019 - 18:52 UTC
This incident affected: Dashboard.